domingo, 1 de noviembre de 2015

CenterIM y Ubuntu 15.10

Qué encontrarás en esta entrada?
  • Instalar CenterIM en Ubuntu 15.10.

ADVERTENCIA:

No me responsabilizo de los posibles riesgos de seguridad que impliquen seguir los pasos detallados en esta entrada.


Acabo de abordar recientemente la siempre estimulante tarea de un formateo. Aunque es recomendable realizarlo de vez en cuando para limpiar basura y actualizar los sistemas operativos, con cada actualización siempre hay algunos problemillas que hay que solventar. Y es que somos animales de costumbres que, una vez acostumbrados a utilizar algo, nos cuesta mucho utilizar otra cosa a no ser que tenga claras y rápidas ventajas con respecto a lo anterior.

Es el caso de CenterIM en Ubuntu 15.10. Por un momento pensé en que iba a tener que renunciar a este ligero cliente de mensajería instantánea que, por otra parte, hace la función de cimientos para el sistema ABSys (el sistema por el cual puedo dar órdenes a mi ordenador desde el móvil, pudiendo acceder a tiempo real a mi equipo y ejecutar distintas tareas, como he documentado alguna vez en este blog).

Según podíamos leer en RSPPI en su día, de donde tomé las bases para ABSys, para instalar CenterIM bastaba con ejecutar en un terminal el siguiente comando:

apt-get install centerim

Sin embargo, esto sólo funciona limpiamente para versiones antiguas de Ubuntu. En la versión 15.10, hay que ir algunos pasos más allá. Al intentar instalar CenterIM de la página oficial, nos encontramos varias alternativas: la versión 5, que hay que configurarla ("./configure"), y la versión 4, que está para configurar también, o en forma de paquete ".deb".

Personalmente, y debido a mi falta de conocimiento, estoy un poco "peleado" con las versiones en "tar.gz" para configurar, porque antes o después llego a un problema irresoluble de dependencias. Éste es también mi caso para las versiones 4 y 5 de CenterIM. Pruebo por tanto los paquetes, pero éstos también tienen problemas de dependencias: fundamentalmente, el paquete "libgnutls26" parece haber sido descatalogado para las nuevas versiones de Ubuntu.

Tras luchar con Synaptic y sus repositorios, encuentro una interesante página en la que se pueden descargar paquetes antiguos de Ubuntu: Ubuntu Updates. Allí no es difícil descargar la librería libgnutls26.

Una vez hecho esto, el problema lo da libgcrypt11, pero resulta que éste también está en Ubuntu Updates.

Después de estos pasos, estamos listos para instalar los paquetes ".deb" de la página de CenterIM. En antiguos repositorios de Ubuntu, accesibles desde la web, también tenemos estos paquetes. Primero hay que instalar la versión "commons" ("centerim-common_4.22.10-2ubuntu1_all.deb"), y después, por ejemplo, la versión "centerim_4.22.10-2ubuntu1_amd64.deb".

Con esto tenemos instalado de nuevo CenterIM en un Ubuntu 15.10.

Resumiendo los pasos:
  1. Instalar libgcrypt11.
  2. Instalar libgnutls26.
  3. Instalar centerim-common_4.22.10-2ubuntu1_all.deb.
  4. Instalar centerim_4.22.10-2ubuntu1_amd64.deb.

No hay comentarios:

Publicar un comentario en la entrada

Querido astarothista!,

Si te ha gustado la entrada y quieres dejar constancia de ello, tienes alguna sugerencia para completarla o corregirla, quieres mostrar tu opinión respecto a algo de lo que se haya hablado en esta entrada (con respeto) o simplemente quieres dejarme un mensaje a mi o a la comunidad, no dudes en comentar ;)!

Recuerda que también estamos en Facebook y en Google+.

Related Posts Plugin for WordPress, Blogger...